Ghostscript

Was this article helpful?
4 out of 7 found this helpful

Let us know what else you'd like to see in this article. to leave a comment below.


Comments

2 comments

  • Avatar
    Dr Brian Conway

    This article is a little confusing if you are installing on a 64 bit server greater than 9.2.2.

    4. Run the installer and complete the installation with the default settings, including the default installation location, as above.

    you have the default in the image above as C:\Program Files (x86)\gs\gs9.18 but in fact the default for 64 bit will not be (x86). but C:\Program Files\gs\gs9.18, so you are left wondering do I change the default or allow the installer to choose the default?

    If you’re running Genie version 8.6.6 or later, Genie will detect the presence of Ghostscript on your computer and it will be linked automatically, but this does not show as linked on the image pro as in the image

    and if you do try to link it you get:  "invalid file Please select the file named 'gsdll32.dll'" even though you have a 64 bit system, and the Where is ghostscript? linking button is still there!

    I think you could tidy it up to encapsulate the various scenarios and remove the ambiguous references.

    0
    Comment actions Permalink
  • Avatar
    Dr Brian Conway

    Just Feedback FYI

    Issue: Email attachment PDF’s being generated in Black and White, but Secure messaging PDF’s (generated on server were in colour)

    Setup: Genie 9.3.4 64 bit server 2016

    Running on Windows 64 bit Server 2016 in a terminal services environment

    Ghostscript 64 bit installed on server as well as PrimoPDF and Microsoft print to PDF

    Ghostscript both 32 bit and 64 bit installed on the  TS client (different server) as well as primoPDF, NitroPDF and FoxitPDF printers (not Microsoft Print to PDF)

     

    My recollection is that prior to Ghostscript installation on the client I did not get the email radio button to send as PDF despite having PDF printers installed and running 9.3.4

     

    Rectification:

    I did 2 things then tested, so can’t be sure which worked! [I tell my patients to do only one intervention at at time but then don't follow my own advice].

    1. Uninstalled Ghostscript 64 on the client (but left gS 32bit)
    2. Installed Microsoft Print to PDF to Client TS server 2016 following this guide:

    https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/how-to-add-or-reinstall-the-microsoft-pdf-printer/70377c34-e50a-42be-b9f3-92345d6e25df

    Retested email PDF attachment generation on the client via Genie:  now generating in colour = success.

    As it is working I haven’t taken the last step of uninstalling Ghostscript 32 on the client to see if the radio button option of sending attachments via PDF disappears, as Genie says not needed, but I am not so sure about that.

    Hope this helps someone else

    Brian Conway Adelaide

     

    0
    Comment actions Permalink